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1. Introduction 

Overview 

In this project, a robust, accurate and inexpensive approach to automatically estimate 
mass 3D facial motion trajectories is proposed. This system is an extension of our previous 
tracking procedure, "RFAP: Realistic 3D Facial Animation Parameters from Mirror-reflected 
Multi-view Video"[6]. For facial marker tracking, a single digital video camcorder and two 
plane mirrors are utilized to capture frontal and side views of a face simultaneously. In 
addition, Ultraviolet (UV) "black light blue"(BLB) lamps are applied to enhancing the 
distinctness of markers in video clips for more reliable feature extraction. In order to be 
automatic tracking, the temporal and spatial coherence of facial markers' motion are utilized 
to detect and rectify false tracking and tracking conflict. Such a large quantity of facial 
motion parameters can provide more faithful surface deformation for facial animation, and 
they can also be applied to further analysis of facial motion. Currently, the system can 
automatically track 188 markers at 12.75 fps and 300 markers at 9.2 fps from video clips on a 
Pentium4 3.0GHz PC, and it will be extended to be a live motion tracking system in the near 
future.  

 Figure 1 is the flow diagram of the tracking procedure. A few user interventions are 
required for initialization. After setting up tracking devices, the parameters of these devices 
are first evaluated, and the facial markers’ 3D structure in the 0th frame are estimated. Our 
system then can fully automatically track and extract facial motion trajectories from the 
following video clips. At frame t, a feature extraction process is used to estimate markers’ 
projection positions, and potential 3D candidates are constructed from valid point 
correspondences. The system can then search the best markers’ 3D positions from 3D 
candidates after head motion is removed. Since markers in video clips may occasionally 
disappear or be misjudged due to occlusion or noise disturbance, missing markers can result 
in false tracking and tracking conflicts. While false tracking or conflict is detected by our 
system, a rectification process will be performed. Moreover, adaptive Kalman filters and 
predictors are also utilized to improve the stability of tracking, 
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Figure 1. The flow diagram of the automatic 3D motion tracking.



System requirement 

DV camera × 1 

Plane mirror × 2 Devices 
UV black light blue lamp × 2 ~ 4 

OS Microsoft Windows 2000/XP 

CPU Intel Pentium III or AMD Athlon 1GHz or above 

RAM At least 256MB 

Mathworks Matlab C math library version 2.1 or later versions. 
(Matlab C math library v2.1 is included in Matlab v6.1) 

Microsoft DirectX v8.1 or later versions. 
Software library 

OpenGL dll. 
 
(The DV camera used in authors’ experiment is SONY DCR-VX2000) 
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2. Equipment setting 
The equipment setting of our tracking system is shown in Figure 2. Two mirrors and two 

black light blue lamps are placed in front of a digital video (DV) camcorder. We usually 
make the included angle between a mirror’s normal and the camera’s optic axis around 30~45 
degrees. But, it is not absolutely necessary. The orientations and locations of mirrors can be 
arbitrary, as long as the front- and side-view images of a subject’s face can be included in the 
camera’s field of view (as shown in Figure 3). 

After confirming the camera’s view field including the frontal and two side views, the 
mirrors, the camera, and also the intrinsic parameters of the camera have to be fixed. (Please 
turn off the auto-focus, auto-white-balance, etc. of the camera.) We utilize J.-Y. Bouguet’s 
camera calibration toolbox [2] to evaluate the intrinsic parameters (including focal lengths, 
camera distortion, etc.). In the following statement, the coordinate system is normalized and 
undistorted based on the intrinsic parameters, called the normalized camera model. 

Here, brief introductions to 3D structure from mirrored-reflected multi-view video and 
the efficacy of UV blacklight blue lamps are presented as follows. 

3D structure and mirror-reflected multi-view video 

The mirrored image can be regarded as a “flipped” image taken by a “virtual camera”, 
which is in a distinct view direction comparing to the physical one. With two mirrors next to 
a subject’s face, we can simultaneously acquire three facial images from different viewpoints 
and we can also avoid the problem of data synchronization among different cameras. 

Before we use these images for 3D position estimation, orientations and locations of 
mirror planes must be estimated in advance. Some research required explicit measuring these 
properties. Explicit measurement is not user-friendly and not reliable, or precise devices must 
be employed. Hence, accurate methods to handle the whole process from image sequences 
are necessary. 

In some related researches, 3D positions of the aforementioned configuration were 
estimated by modified general-purpose stereovision approaches. These approaches regard the 
mirrored view as a symmetric virtual camera and estimate the affine transformation (rotation 
R, translation T) between two cameras from the essential matrix. After evaluating the rotation 
and translation between two cameras, the 3D position of a target can then be approximated 
from intersection of cast rays from optical centers of different cameras. 

However, there are some nice properties of mirrored images that can be utilized to get a 
more accurate result. Therefore, we proposed an accurate and robust closed-form 3D position 
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estimation method from mirror-reflected multi-view video. It first evaluates the plane 
equation of mirrors in space, and 3D positions can be estimated from the relation of point 
correspondences and mirror planes. For the detailed algorithm and discussion, users’ can 
refer to our publications [5, 6]. 

Markers and UV blacklight blue lamps 

In order to enhance the distinctness of markers from others in video clips, we apply 
UV-responsive markers and UV blacklight blue (BLB) lamps. Here, an introduction to these 
devices and the UV light are briefly mentioned. 

Ultraviolet (UV) light represents a section of the light spectrum, extending from the blue 
end of the visible (400nm) to the x-ray region (100nm). It can activate some materials, such 
as phosphors, to the luminescence condition. Luminescence is composed of fluorescence and 
phosphorescence. The main difference between these two conditions is the period of radiation. 
Fluorescence vanishes but phosphorescence continues for a while as the UV radiation stops. 
UV light is further divided into three regions, UV-A, UV-B, and UV-C. UV-A light is of the 
longest wavelength (400nm-315nm) and the lowest energy among three regions and is also 
referred to as “black light”. Since the black light is less harmful comparing to the most 
aggressive component UV-B, it is usually used to detect counterfeit money in banks or for 
visual effects in nightclubs or theaters.  

In the proposed tracking system, we also utilize the fluorescent phenomenon to 
emphasize markers in video clips. Markers are covered with fluorescent pigments and 
blacklight blue lamps are used to excite the fluorescence. Users can easily find and purchase 
UV blacklight lamps and fluorescent paper or paint in upholstery stores or toy stores. 

Figure 2 is a photo of the proposed tracking equipment taken under normal light and 
Figure 3 is a video clip captured by a digital video camera, where fluorescence of markers is 
excited by UV light. (Note: The Figure 3 is taken in visible light spectrum without any 
special attachment lens.) A marker’s fluorescent color illuminated by UV light is quite 
different from that illuminated by normal light. In our experiment, we classify fluorescent 
colors into 4 groups, purple, pink, green, and blue. An appropriate marker is about 3~4mm in 
diameter, and the distribution of markers should be dense and even because the detection and 
rectification of false tracking require motions in the neighborhood. For further introduction of 
UV light and luminescence, please refer to the bibliography [4]. 

Another issue for marker placement is head motion. If the subject’s head keeps 
stationary (e.g. his/her head is fixed to fixed supports), the markers’ trajectories can be 
regarded as his facial motion. However, if it is not fixed, the markers’ trajectories will consist 
of both facial motion and head motion. Therefore, to evaluate head motion, we attach six 
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special markers on a subject’s ear and one on the tip of the concave on the nasal column (as 
shown in Figure 3). The number of the head motion markers should be at least three; it can be 
more reliable if the number is more than seven. If the head is fixed, no special marker is 
required.
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Figure 2. The tracking equipment. The photo is taken under normal light. Two “blacklight
blue”(BLB) lamps are placed in front of a subject and mirrors. The low-cost special lamps
are coated with fluorescent powders, and it can emit long wave UV-A radiation to excite
luminescence. 
 

 

 

Figure 3. A captured video clip of fluorescent markers illuminated only by UV “Blacklight 
Blue” lamps. The image is captured in visible light spectrum without any special attachment 
lens. 200 markers are evenly pasted upon a subject’s face. 
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3. The tracking procedure 
In this chapter, a complete procedure to operate the tracking software tool is introduced. 

Before applying the tracking procedure of our system, two optional preprocess steps 
should be performed in advance in order to improve the accuracy and reduce users’ 
assistance. 

Preprocess A. (Optional) Camera calibration for the intrinsic parameters 

The camera calibration processes have been developed for decades. With a calibrated 
camera system, the reconstructed 3D positions and trajectories can be more accurate. 
Recently, J. Heikkilä and O. Silvén’s procedure [1] and Z. Zhang’s procedure [3] are widely 
used. In our work, we use and recommend a well-developed camera calibration toolbox for 
Matlab by J.-Y. Bouguet [2]. 

Preprocess B. (Optional) Acquiring the 3D structure of a subject’s neutral face 

In our tracking procedure, we require each marker’s 3D position in the 0th frame (the 
neutral face). This is equivalent to find out each marker’s projected point correspondences in 
the frontal view and a side view. We utilize 3D scanned depth information of the neutral face 
to find the correspondence automatically (as shown in Figure 4). The scanned data should be 
prepared in the “CSN” file format (as listed in the appendix). While lacking the 3D structure, 
users’ have to manually designate the point correspondence of each marker in the first frame. 

 

 

Figure 4. A 3D laser scanner is employed to acquire depth range images of a subject’s face. 
We integrate two to three range scans for a complete face 3D structure. 
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The following steps are completely provided by our tracking tool. The instructions 
within braces { } are the operations to perform the corresponding step in our system. The Step 
2 to Step 11 is the initialization steps of our tracking. These steps collect information in the 
0th frame in video for the successive tracking. 

 Note: The parameters assigned or calculated in Step 2 to Step 11 can be exported or 
imported by {Quick L/S→Save input arguments} or {Quick L/S→Load input 
arguments} through a file “X.arg”, where X is the video file’s name. Please frequently 
save and backup the parameters. 

 

Step 1. Inputting a video file 
{File→Open clip} 

Since our video decoding is based on the framework of Microsoft DirectShow, our 
system can recognize and operate on all 720x480-pixel video formats (MS DV AVI, MPEG2, 
etc.) as long as the corresponding decoders (DirectShow filters) are installed.  

However, the performance of our system therefore depends on the installed decoder. In 
our experiments, the most computationally efficient and reliable format is MS DV AVI. The 
operation of step seeking may occasionally halt our program while adopting the decoder of 
Cyberlink PowerDVD version 3.0 for MPEG-2 video, but it work well while using the 
decoder of PowerDVD version 4.0. 

 

Step 2. Assigning camera intrinsic parameters 
{2D Tools→Camera intrinsic parameters} 

In this step, focal lengths, the principal point, skew coefficient, and distortions, which 
are evaluated in Preprocess A, have to be filled in the dialogue box. We follow the denotation 
used in J.-Y. Bouguet’s calibration toolbox. The default values are fcX=fcY=1500, ccX=360, 
ccY=240, alpha_c=0, and kc1=kc2=kc3=kc4=0. 

 

Step 3. Assigning boundaries of right, front and left views 
{2D Tools→Assign R,F,L boundaries} 

This step is to assign the boundaries of right, frontal and left view. Our system will only 
process these 3 designated regions for all video clips.  

A visualization window “Result Display” is provided for display of the result image of a 
video clip after image process operations. It can be switched on by {View→Result display 
(on/off)}. Users’ can dump a video clip to the ResultDisplay window by {2D 
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Tools→Capture ith frame} and check whether the boundaries of right, front, and left regions 
are appropriate (as shown in Figure 5). 

 

Figure 5. The assignment of right, frontal, and left views’ boundaries. 

 
Step 4. Adjusting color threshold 

This step is utilizing color thresholding to roughly separate pixels belong to markers and 
others in a video clip. Users’ can first dump the 0th video clip to the ResultDisplay window 
by {2D Tools→Capture ith frame} and gather the color histogram by {2D Tools→Color 
histogram (the current fm)}. The histogram will display in another auxiliary visualization 
window “Info”. It can be switched on by {View→Info Display (On/Off)}. To adjust the 
color threshold, press “F3” while the Info window is the focus window (as shown in Figure 
6). 

 

Figure 6. Adjusting the color histogram. 

Pixels that pass the threshold are shown in the Result Display window. Users can switch the 
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output image to the binary display mode by {View→Switch Binary/Color} for a more 
distinct presentation. 

 

Figure 7. Pixels that pass the threshold (in the binary display mode). 

 

Step 5. Assigning the color classes 

{2D Tools→Assign the amount of cSamp} 

First, the total amount of color classes is assigned (4 in our case), and it shows current 
color samples by {View→View color samples} (as shown in Figure 8). 

 

Figure 8. The Info window display information of color samples 

The color classification in our system is based on the nearest neighbor approach, where 
the color of a pixel will be classified into the color class with the nearest color members. 
Each color class can have 16 members at most. For example, to add a color member in color 
class no. 2, a use can press “2” on keyboard to set color class no. 2 as the current target color 
class. Then, he can move the mouse to a desired position in the ResultDisplay window and 
click the right mouse button to add the color at the desired position as a new member of 
color class no.2 (as shown in Figure 9). (As mentioned above, users’ can dump a video clip to 
the ResultDisplay window by {2D Tools→Capture ith frame}.) 
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Figure 9. Adding a color as a new color member by designating a position in the Result 
display window. 

 

Step 6. Color labeling of the 0th frame 

In this step, each pixel that passes through the threshold is classified into a color class 
defined in Step 5. The operation is {2D Tools→Color labeling}. {Views→Switch 
color/color label} can show the color-labeled image in the ResultDisplay window. (Each 
pixel in the result image is shown in the typical color of its color class.) 

If the result is not appropriate or satisfactory, go back to Step 5 and change color classes 
or add color members. 

 

Figure 10. The result image of color labeling. 

 

Step 7. Feature extraction (Connected component labeling) of the 0th frame 

By grouping connected valid pixels of the same color class, markers’ projected positions 
can be extracted. Here, we use a simplified connected-component-labeling method instead of 
the classical ones since the projection of a marker is usually within a radius of 3~5 pixels. 
The operation is {2D Tools→Connected component labeling→R,F,L simplified connected 
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component labeling}. A refining operation {2D Tools→Connected component 
labeling→Refine R,F,L ConnectedComponentLabel objects} is also provided for merging 
redundant connected components caused by interlaced effects, noise, etc. The result can be 
dumped in the ResultDisplay window by {View→Switch color label (+ center)}. 

  

Figure 11. Simplified connected component labeling and the refinement. Red crosses are the 
extracted positions of markers. 

 
Step 8. Assigning boundaries of the right-face and left-face in the front view 

{2D Tools→Assign FR’s and FL’s boundaries} 

To reduce the searching regions during matching, rough boundaries of the righ-face and 
left-face regions in the front view have to be designated in terms of inequalities. The two 
regions should be overlapped. The result boundaries are shown in the ResultDisplay window 
{View→Switch color label (+ center)}. 

 
Step 9. Mirror plane estimation 

In this step, right (face) and left (face) mirrors’ plane equations are evaluated from 
projected point correspondences and they can be used for 3D position reconstruction in later 
steps. For example, to designate a point pair of color class “1” between the right view and the 
FR region in the frontal view, a user first have to set class no. “1” as the current target color 
by pressing “1” on keyboard. Then, he/she moves the mouse to the place around the target 
point and press “control key + right mouse button”. When designating points in the frontal 
view and in the right view by turns, corresponding point pairs are established. The established 
point corresponding pairs are shown in the ResultDisplay window (as shown in Figure 12). It 
can switch to the left side by pressing “-“ on keyboard.  

After assigning point pairs for right and left mirrors, our system can evaluate the mirror 
plane equations by {3D Calculation→Mirror plane calibration→Mirror plane 
estimation}. We suggest it would be appropriate if more than 10 point-corresponding pairs 
are assigned for each mirror. 
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Figure 12. Designating point correspondences for mirror plane estimation. 

 
Step 10. Calibrating the scale between right-face and left-face coordinate systems 

In the previous step, the scales of coordinate systems of the right and left mirror space 
may not be the same. We can evaluate the scale by comparing the 3D positions of the same 
point set in the right and left mirror coordinates. 

First, in the ResultDisplay window, press “F8” to clear the queue of point pairs. Then, 
designate point correspondences of a set of markers visible in both right and left mirrors (in 
the way similar to that of Step 9). Pressing {3D Calculation→Estimate selected pts’ 3D 
positions} can estimate the 3D positions of selected point correspondences. A window 
“GL3D” is provided for visualization of 3D data, and it is switched on by {View→GL3D 
Display (on/off)}. The scale can then be evaluate by {3D Calculation→Mirror plane 
calibration→Calibrate R,L mirrors from selected 3D pts}. 

 Note: In the GL3D window, it shows only markers of the selected target color. Press 
“0”~”the total amount color class-1” on keyboard can switch the current target color 
number. Press “a number ≥ the total color class amount” can show markers of all 
color classes. 

 
Step 11. (Optional) Transforming the 3D scanned face structure to the camera coordinate 

system 

If there are no 3D scanned data of the neutral face (Preprocess B), skip this step and go 
to Step 12. 

Since the 3D scanned data and the camera coordinate system are different, to utilize the 
3D scanned data, they must be transformed to the same coordinate system. We apply a least 
square method proposed by K.S. Arun [7] to estimating the affine transformation between 
two 3D point sets. An independently auxiliary tool “CSNview” is provided to select feature 
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points from 3D scanned “CSN” data. (as shown in Figure 13). In general, eight to fifteen 
points are sufficient to evaluate accurate affine transformation. The output file should 
conform to the “SCSN” file format as listed in the appendix. In addition, the 3D scanned file 
and the selected points should be placed in the same folder of the video file; they should be 
renamed as “X.csn” and “X.scsn”, where X is the video file name, e.g. “ven_exp.avi”.  

The selection process of the point set from a video clip is the same as that in Step 10. 
First, clear the queue of point pairs. Then, designate point correspondences of a set of 
markers. {3D Calculation→Estimate selected pts’ 3D positions} can estimate the 3D 
positions of selected point correspondences. After the point set from a video clip and the 
point set from 3D scanned data are ready, {3D Calculation→Estimate CSN to V3D from 
selected 3D pts} will calculate the affine transformation. 

 

Figure 13. The CSN viewer “CSNview” is an interactive tool for feature point selection from 
CSN data. 

 
 Note: The parameters input or calculated in the above steps can be exported or 

imported by {Quick L/S→Save input arguments} or {Quick L/S→Load input 
arguments}. The above initialization steps can be performed just once. But the Step1 
and the following steps must be performed every time for tracking. 

 
Step 12. Feature extraction of the 0th frame 

 Dumping the 0th frame by {2D Tools→Capture the ith frame}. 

 Color labeling by {2D Tools→Color labeling (based on samples)}. 

 Extracting projected markers by  
{2D Tools→Connected component labeling→ R,F,L simplified connected 
component labeling} and  
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{2D Tools→Connected component labeling→Refine R,F,L 
ConnectedComponentLabel objects}. 

 

Step 13. Reconstructing markers’ 3D positions of the 0th frame 

If the Step 11 is not skipped, the markers’ 3D positions of the 0th can be evaluated by 
{3D Calculation→Reconstruct markers’ 1st frame 3D structure→Estimate 
corresponding points by CSN data}. Since there may be some “holes” in 3D scanned data, 
a radial-basis-function (RBF) based interpolation is also provided to conjecture point 
correspondences at places without 3D scanned data {3D Calculation→Reconstruct 
markers’ 1st frame 3D structure→ Estimate corresponding points of NonCSN by RBF}. 
The result is shown in the GL3D display window by {3D Calculation→Estimate selected 
pts’ 3D positions} (as shown in Figure 15). 

 

Figure 14. Estimation of point correspondences that uses 3D scanned data. 

 
Figure 15. The reconstructed markers’ 3D structure that fit the 3D scanned neutral face. 
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The automatic estimation of 0th-frame markers’ 3D structure may not be perfect. Editing 
functions can be used for modification. To include a 3D marker manually, a user can just add 
the marker’s projected point correspondence (similar to the part in Step 9). For exclusion of 
an estimated 3D marker, a user can point out a 3D point and press the “right mouse button” 
to select the 3D point into the selected queue. Then, he can press “DELETE” on keyboard to 
remove points in the selected queue. After the markers’ 3D structure is determined, users 
should press {3D Calculation→Estimate selected pts’ 3D positions} again and {3D 
Calculation→Reconstruct markers’ 1st frame 3D structure→Determine the 1st-frame 
corresponding point} 

If the Step 11 is skipped, a user has to designate the point corresponding manually as 
Step 9. Then, he/she has to press {3D Calculation→Estimate selected pts’ 3D positions} to 
reconstruct 3D positions and {3D Calculation→Reconstruct markers’ 1st frame 3D 
structure→Determine the 1st-frame corresponding point}. 

 

Step 14. (Optional) Specifying the special “head motion markers” 

If special head motion markers are pasted on a subject’s head, this step is operated to 
designate their positions. First, the selected 3D pts queue of the GL3D window should be 
clear by pressing “F9”. Then, users can select the head motion markers by pointing out the 
corresponding 3D points and press the “right mouse button”. At last, {3D 
Calculation→HeadMov evaluation→Set current selected 3D pts as HeadMov markers} 
and {3D Calculation→HeadMov evaluation→Set avg of current selected 3D pts as the 
HeadMov center} set the HeadMov markers and the head motion center respectively. 

 

Figure 16. The selected 3D point set for head motion estimation. 
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Step 15. Extracting facial animation parameters and head motion 

{3D Calculation→FAP Extraction} will start to extract facial animation parameters 
and head motion frame by frame from video clips. Three display modes in the GL3D window 
are provided for visualization, and they can be switched by {View→Switch CorPt3D/Trj3D} 
and {View→Switch Trj3D/Disp3D} (as shown in Figure 17). 

 

Figure 17. The three display modes from left to right are “Potential CorPt3D”, “Estimated 
Trj3D”, and “Estimated Disp3D”. At time t, the “Potenial CorPt3D” mode shows 3D points 
generated from all potential point correspondence conformed to the mirrored epipoloar lines 
[5]. The “Estimated Trj3D” mode shows the estimated markers’ 3D positions. The “Estimated 
Disp3D” mode shows the difference vectors of estimated positions between time t and 0. 
 
 Input and output of estimated motion trajectories 

{File→Import T3D} 

{File→Export T3D} 

{File→Export N3D} 

{File→Export R3D} 

The I/O of the estimated facial motion trajectories and head motion can through “T3D”, 
“N3D”, and “R3D” files. The detailed file format are listed in the appendix.  

To playback a Trj3D file, first load the video file as Step 1, and load the corresponding 
argument file {Quick L/S→Load input arguments}. Then import the Trj3D file by 
{File→Import T3D}. The motion trajectories can be played in the “Disp3D” mode of the 
GL3D window ({View→GL3D Display (on/off)} and {View→Switch Trj3D/Disp3D}) by 
{3D Calculation→Playback Trj3D}.  
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Appendix: File format 

CSN file 

A CSN file stores 3D scanned data. We explain the format in an example: 
Unit: 
MM 
Number of Sections: 
3 
Section begin 
262.012085 153.541672 63.865833 53 15 0 
Section end 
Section begin 
257.033142 151.617767 63.191460 128 69 53 
256.949188 151.727814 64.289513 127 72 59 
256.874420 151.807938 65.398438 130 66 65 
256.800049 151.818222 66.471764 128 68 61 
256.743927 151.715866 67.539085 124 64 53 
256.701782 151.666260 68.668610 126 58 45 
256.656067 151.632278 69.797775 123 58 49  
Section end 
Section begin 
260.455322 153.002014 62.071178 22 0 0 
260.370667 152.969879 63.097057 81 24 37 
260.336456 152.767746 64.166924 111 55 51 
260.286407 152.685989 65.254570 123 58 62 
Section end 

The first three lines are invariable, and the 4th line defines how many scan lines are listed 
in the following. Each scan line begins with “Section begin” and ends with “Section end”. It 
can comprise hundreds of points in the format “X Y Z R G B”, where (X,Y,Z) is the point’s 
3D position and (R,G,B) is the color 
 

SCSN file 

A SCSN file stores selected feature points from a CSN file. For example, 
6 
213.579956 51.133942 128.560150 
120.369606 51.276310 122.732651 
172.851105 35.298702 37.984573 
170.673874 77.500999 -25.000847 
173.201187 44.737663 88.983360 
206.893265 79.900322 7.164515 

The first line is the number of valid selected points plus 1. In this example, the first 5 
points are valid and the last one is not used in the current system. 
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T3D file 

A T3D file stores facial motion trajectories and their conditions. For example, 
T3D: 2 frames 3 color e:\test.avi 
[c 0] ( 244 223 241 ) (FR 1 pts) (FL 2 pts) 
[c 1] ( 182 158 225 ) (FR 1 pts) (FL 1 pts) 
[c 2] ( 177 241 241 ) (FR 2 pts) (FL 1 pts) 
<Neutral Face> 
[c 0 FR] ( -0.3370261944 -0.0430717884 7.2966577369 ){1} 
[c 0 FL] ( 0.0185317636 -0.0614443803 6.8974352629 ){1} ( 0.3481377754 -0.0468638419 
7.2473075478 ){1} 
[c 1 FR] ( -0.3067886625 -0.0442611540 7.2675426900 ){1} 
[c 1 FL] ( 0.0497755896 -0.0588067445 6.9140420154 ){1} 
[c 2 FR] ( -0.3131138040 0.0146998201 7.2637296403 ){1} ( -0.1278074142 -0.1918733195 
6.9309054378 ){1} 
[c 2 FL] ( 0.3720504788 -0.0581366341 7.2764051686 ){1} 
<Frame 0> 
[c 0 FR] ( 0.0000000000 0.0000000000 0.0000000000 ){1} 
[c 0 FL] ( 0.0000000000 0.0000000000 0.0000000000 ){1} ( 0.0000000000 0.0000000000 
0.0000000000 ){1} 
[c 1 FR] ( 0.0000000000 0.0000000000 0.0000000000 ){1} 
[c 1 FL] ( 0.0000000000 0.0000000000 0.0000000000 ){1} 
[c 2 FR] ( 0.0000000000 0.0000000000 0.0000000000 ){1} ( 0.0000000000 0.0000000000 
0.0000000000 ){1} 
[c 2 FL] ( 0.0000000000 0.0000000000 0.0000000000 ){1} 
<Frame 1> 
[c 0 FR] ( 0.0003624232 0.0002569703 0.0002603337 ){1} 
[c 0 FL] ( 0.0000133199 0.0002610039 -0.0009920909 ){1} ( 0.0005702935 0.0005169562 
0.0000810597 ){1} 
[c 1 FR] ( -0.0002012788 0.0002914486 -0.0007765289 ){1} 
[c 1 FL] ( -0.0007585459 -0.0002900024 -0.0001320602 ){1} 
[c 2 FR] ( -0.0002572608 -0.0004968918 0.0004121068 ){1} ( -0.0002152945 0.0001257728 
0.0000211152 ){1} 
[c 2 FL] ( 0.0002412231 0.0001892649 0.0003941148 ){1} 

The first line notes that there are 2 frames, 3 color classes, and the last part is users’ 
annotation. The following 3 lines record these 3 color classes’ information. For instance, the 
line 4 show that the typical color of the color class no.2 is (177 241 241) and there are 2 
extracted markers on the right face and 1 marker on the left face. 

The <Neutral face> records the markers’ 3D positions of the neutral face condition. [c 
X FR(or FL)] is the tag to annotate the following points belong to color class X and the 
right(or left) face. The number in the brace is an internal state and it can be omitted. 

The following sections are data of each frame. The data format of <Frame t> is similar 
to that of the <Neutral face> section. However, the 3D vector of a point is now its position 
difference between time t and the neutral face (the 0th frame) instead of the point’s position. 
 

N3D file 

A N3D file is a simplified file format of T3D. It consists of only the facial motion 
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trajectories. For example, 
N3D: 4 frames 2 points [focus 1.00000000] [datum 8.00000000] e:\test.avi 
NA: (-0.3370261944 -0.0430717884 7.2966577369)(-0.1778434939 -0.1805258923 6.9820805344) 
(0.0000000000 0.0000000000 0.0000000000)(0.0000000000 0.0000000000 0.0000000000) 
(0.0003624232 0.0002569703 0.0002603337)(-0.0003571076 -0.0009193555 -0.0000341894) 
(0.0002466609 0.0007950537 -0.0001041981)(-0.0004064079 -0.0005849222 -0.0004963622) 
(0.0004299661 0.0003315497 -0.0001511599)(-0.0005630545 -0.0009178430 -0.0004845413) 

The first line notes that there are 4 frames, 2 extracted points. The focus and datum are 
internal variables that can be omitted, and the last part is still users’ annotation. The second 
line is about markers’ 3D positions in the neural face. Each line in the following comprises 
markers’ 3D position difference of this frame with respect to the neutral face. 
 

R3D file 

A R3D file stores the evaluated head motion. For example, 
3 frames [neutral 0]  
[0] 
R1 (1.000000 0.000000 0.000000) 
R2 (0.000000 1.000000 0.000000) 
R3 (0.000000 0.000000 1.000000) 
t  (0.000000 0.000000 0.000000) 
[1] 
R1 (0.999999 -0.000862 0.000282) 
R2 (0.000862 0.999999 -0.000108) 
R3 (-0.000282 0.000108 0.999999) 
t  (0.000194 0.000196 -0.000011) 
[2] 
R1 (0.999999 -0.000806 -0.000262) 
R2 (0.000806 0.999999 0.000141) 
R3 (0.000262 -0.000141 0.999999) 
t  (0.000117 -0.000079 -0.000513) 

The first line specifies that there are 3 frames and the neural head pose is at frame 0. The 
head motion can be represented as rotation R and translation t with respect to the neural head 
pose. H(i) = R(i)H(0) + t(i), where H(i) is a point on the head at time i, R(i) is the head 
rotation at time i, and t(i) is the head translation at time i. 

R1 is the first column of the rotation matrix, R2 is the second and R3 is the third. And 
therefore, in this example, 
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